summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-12-01 01:32:02 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-12-01 01:32:02 +0000
commitb2e137c81e70ca23676d5847be8719db8df2e5a6 (patch)
treea678bebffddb332800004519b3d355d547875ee1 /configure.in
parent05f423abc690ef88c1cb2453dfee5667843d793a (diff)
* configure.in (LDFLAGS): -fstack-protector is always needed to
link static library created with it. [ruby-core:41387] [Bug#5686] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@33914 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index e37849eadc..e685913c33 100644
--- a/configure.in
+++ b/configure.in
@@ -510,6 +510,7 @@ if test "$GCC" = yes; then
if test "x$stack_protector" = xyes; then
RUBY_APPEND_OPTION(XCFLAGS, -fstack-protector)
RUBY_APPEND_OPTION(XLDFLAGS, -fstack-protector)
+ RUBY_APPEND_OPTION(LDFLAGS, -fstack-protector)
fi
# suppress annoying -Wstrict-overflow warnings