summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2010-03-16 05:03:30 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2010-03-16 05:03:30 +0000
commitacd2d29f2e48ef0644a14b41f74f7a380a09a135 (patch)
tree72f11add5a2eccc739d7e6efdd11b525cf01cf7c /configure.in
parentb215b9742ecdc7c3771d305400f72bd76946277e (diff)
* configure.in (RSHIFT): parenthesize the argument of cast instead
of the result. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@26949 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 6675d783a4..c42788d8c3 100644
--- a/configure.in
+++ b/configure.in
@@ -1349,9 +1349,9 @@ AC_CACHE_CHECK(whether right shift preserve sign bit, rb_cv_rshift_sign,
rb_cv_rshift_sign=yes,
rb_cv_rshift_sign=no)])
if test "$rb_cv_rshift_sign" = yes; then
- AC_DEFINE(RSHIFT(x,y), ((x)>>((int)y)))
+ AC_DEFINE(RSHIFT(x,y), ((x)>>(int)(y)))
else
- AC_DEFINE(RSHIFT(x,y), (((x)<0) ? ~((~(x))>>(y)) : (x)>>(y)))
+ AC_DEFINE(RSHIFT(x,y), (((x)<0) ? ~((~(x))>>(int)(y)) : (x)>>(int)(y)))
fi
test "$rb_cv_fcnt" = "not found" && rb_cv_fcnt="not found (OK if using GNU libc)"