summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2005-01-31 15:20:59 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2005-01-31 15:20:59 +0000
commitac3499a0fa7f986628a65a299f8690bf0f96a3f0 (patch)
tree576fa77e308a463f785853d09d605712b2e404cf /configure.in
parent420a708098527c816ab0437f58e111ecae9c2211 (diff)
* configure.in (aix): fix linker flags on AIX. [ruby-talk:125460]
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@7857 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 1560323f53..ee5954c86a 100644
--- a/configure.in
+++ b/configure.in
@@ -880,11 +880,10 @@ if test "$with_dln_a_out" != yes; then
rb_cv_dlopen=yes ;;
aix*) : ${LDSHARED='/usr/ccs/bin/ld'}
XLDFLAGS="$XLDFLAGS -Wl,-bE:ruby.imp"
- DLDFLAGS='-brtl -bI:$(topdir)/ruby.imp -bM:SRE -T512 -H512 '"$DLDFLAGS"
- ARCH_FLAG='-eInit_$(TARGET)'
- : LDFLAGS="-brtl $LDFLAGS"
+ DLDFLAGS='-brtl -eInit_$(TARGET) -bI:$(topdir)/ruby.imp -bM:SRE -T512 -H512 '"$DLDFLAGS"
+ LDFLAGS="-brtl $LDFLAGS"
: ${ARCHFILE="ruby.imp"}
- TRY_LINK='$(CC) $(DLDFLAGS) -oconftest $(INCFLAGS) -I$(hdrdir) $(CPPFLAGS) $(CFLAGS)'
+ TRY_LINK='$(CC) $(LDFLAGS) -oconftest $(INCFLAGS) -I$(hdrdir) $(CPPFLAGS) $(CFLAGS)'
TRY_LINK="$TRY_LINK"' $(src) $(LIBPATH) $(LOCAL_LIBS) $(LIBS)'
: ${LIBPATHENV=SHLIB_PATH}
rb_cv_dlopen=yes ;;