summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-04-06 14:16:10 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-04-06 14:16:10 +0000
commitaa75b002de21dfeb4ab0f3ca9bc0d50a3dd5b65c (patch)
tree286247503fc9ecc9698b19739cc125b858d4454e /configure.in
parentd456f0aabe786310116cbe2cedaf01c97e6070bb (diff)
* configure.in (CFLAGS, CXXFLAGS): override with $cflags and
$cxxflags if not given. [ruby-core:23130] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@23143 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 6 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 7a48d3e137..10b4e76e8c 100644
--- a/configure.in
+++ b/configure.in
@@ -216,12 +216,13 @@ dnl Checks for programs.
if test -z "${CFLAGS+set}"; then
orig_cflags="$cflags"
- cflags="$cflags "'${optflags} ${debugflags} ${warnflags}'}
+ cflags="$cflags "'${optflags} ${debugflags} ${warnflags}'
fi
if test -z "${CXXFLAGS+set}"; then
orig_cxxflags="$cxxflags"
- cxxflags="$cxxflags "'${optflags} ${debugflags} ${warnflags}'}
+ cxxflags="$cxxflags "'${optflags} ${debugflags} ${warnflags}'
fi
+
if test x"${build}" != x"${host}"; then
AC_CHECK_TOOL(CC, gcc)
fi
@@ -347,8 +348,8 @@ if test "$GCC:${warnflags+set}:no" = yes::no; then
warnflags="-Wall -Wno-unused-parameter -Wno-parentheses ${warnflags+$warnflags }-Wpointer-arith -Wwrite-strings"
fi
-test -n "${cflags+set}" && CFLAGS="${CFLAGS} `eval echo $cflags`"
-test -n "${cxxflags+set}" && CXXFLAGS="${CXXFLAGS} `eval echo $cxxflags`"
+test -z "${ac_env_CFLAGS_set}" -a -n "${cflags+set}" && CFLAGS="`eval echo $cflags`"
+test -z "${ac_env_CXXFLAGS_set}" -a -n "${cxxflags+set}" && CXXFLAGS="`eval echo $cxxflags`"
dnl check for large file stuff
mv confdefs.h confdefs1.h
@@ -2219,7 +2220,7 @@ if test "${ARCH_FLAG}"; then
LDFLAGS=`echo "$LDFLAGS" | sed "s|$archflagpat"'|$(ARCH_FLAG)|'`
fi
AC_SUBST(cppflags, [])dnl
-AC_SUBST(cflags, ["$orig_cxxflags "'${optflags} ${debugflags} ${warnflags}'])dnl
+AC_SUBST(cflags, ["$orig_cflags "'${optflags} ${debugflags} ${warnflags}'])dnl
AC_SUBST(cxxflags, ["$orig_cxxflags "'${optflags} ${debugflags} ${warnflags}'])dnl
AC_SUBST(optflags)dnl
AC_SUBST(debugflags)dnl