summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-06-13 13:18:05 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-06-13 13:18:05 +0000
commita9ff01cdae59a09c71d23c9197fa692be28c5c5c (patch)
treefd4d9f7b8fa308909f170e74dca4719537b52ec3 /configure.in
parent0d86842f619413b1199a23ed4c4c4b5bb3f78af1 (diff)
configure.in: option for darwin
* configure.in: remove -ansi and -std options for lgamma_r() and finite(). git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@36065 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 359564b91f..565f4754b2 100644
--- a/configure.in
+++ b/configure.in
@@ -617,8 +617,8 @@ if test "$GCC" = yes; then
# comments. We bypass ANSI C mode for them. Otherwise
# extension libs cannot include those headers.
],
- [cygwin*], [
- # ditto
+ [cygwin*|darwin*], [
+ # need lgamma_r(), finite()
],
[
# ANSI (no XCFLAGS because this is C only)
@@ -1116,7 +1116,7 @@ AS_CASE(["$target_os"],
[openstep*], [ ],
[rhapsody*], [ ],
[darwin*], [ RUBY_PREPEND_OPTION(LIBS, -lobjc)
- RUBY_APPEND_OPTIONS(CPPFLAGS, -D_XOPEN_SOURCE -D_DARWIN_C_SOURCE -D_DARWIN_UNLIMITED_SELECT)
+ RUBY_APPEND_OPTIONS(CPPFLAGS, -D_XOPEN_SOURCE -D_DARWIN_C_SOURCE -D_DARWIN_UNLIMITED_SELECT -D_REENTRANT)
AC_MSG_CHECKING(whether Mac OS X 10.5 or later)
AC_TRY_CPP([#include <AvailabilityMacros.h>
#if MAC_OS_X_VERSION_MAX_ALLOWED <= 1040