summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoryugui <yugui@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-08-27 01:22:53 +0000
committeryugui <yugui@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-08-27 01:22:53 +0000
commita66b2c6df162f222f0adbbc027818326671fd9a1 (patch)
treeafa39b61f5ea4a6fec20822315c042cf838b20d7 /configure.in
parent51463abb6898e772ff360cb0a4497183776d0f89 (diff)
* nacl/GNUmakefile.in (CC, LD, NM, AR, AS, RANLIB, OBJDUMP, OBJCOPY)
Rewrites these variables instead of PATH. NaCl port uses a toolchain which is specified by NACL_SDK_ROOT environment variable. Originally, NaCl build added the toolchain under the NACL_SDK_ROOT to the PATH. But updating PATH doesn't work on Mac. (RBCONFIG): Replaces configs with the variable updates above. * configure.in: Thus it is no longer necessary to check $PATH. Based on a patch by Takashi Toyoshima <toyoshim AT gmail.com>. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@36828 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 1 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index b490c45219..ec144d2a4c 100644
--- a/configure.in
+++ b/configure.in
@@ -111,11 +111,7 @@ AC_DEFUN([RUBY_NACL],
AC_MSG_RESULT(${NACL_TOOLCHAIN})
AC_MSG_CHECKING([path to SDK])
- if echo -- "${PATH}" | grep -F "${NACL_SDK_ROOT}/toolchain/${NACL_TOOLCHAIN}/bin" > /dev/null; then
- AC_MSG_RESULT([set])
- else
- AC_MSG_RESULT([no])
- AC_MSG_WARN([Add "${NACL_SDK_ROOT}/toolchain/${NACL_TOOLCHAIN}/bin" to \$PATH])
+ if ! echo -- "${PATH}" | grep -F "${NACL_SDK_ROOT}/toolchain/${NACL_TOOLCHAIN}/bin" > /dev/null; then
PATH="${PATH}:${NACL_SDK_ROOT}/toolchain/${NACL_TOOLCHAIN}/bin"
fi