summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2013-08-19 04:03:22 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2013-08-19 04:03:22 +0000
commita3b4296369a2456c6ec95820b87bb686d50bf64e (patch)
tree31b52e427a4985d4ad270b31533a7f510ea0832b /configure.in
parent0a0c96308f69da9e49809d2dd8671d13777aca90 (diff)
configure.in: clock_gettime
* configure.in (clock_gettime): should not overwrite cache variable with different condtion. otherwise -lrt is not linked and the link fails, after reconfig. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@42616 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 62aaf72f5f..0957385ce1 100644
--- a/configure.in
+++ b/configure.in
@@ -1860,8 +1860,9 @@ if test x"$ac_cv_func_clock_gettime" != xyes; then
# glibc 2.17 moves clock_* functions from librt to the main C library.
# http://sourceware.org/ml/libc-announce/2012/msg00001.html
AC_CHECK_LIB(rt, clock_gettime)
- unset ac_cv_func_clock_gettime
- AC_CHECK_FUNCS(clock_gettime)
+ if test x"$ac_cv_lib_rt_clock_gettime" = xyes; then
+ AC_DEFINE(HAVE_CLOCK_GETTIME, 1)
+ fi
fi
AC_CACHE_CHECK(for unsetenv returns a value, rb_cv_unsetenv_return_value,