summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoreban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2003-12-27 14:45:48 +0000
committereban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2003-12-27 14:45:48 +0000
commit9eca8a4a5f27532791ffad5196a150153f3d4a84 (patch)
treea9ff4f10522381b8734dfe463e44b0205f056643 /configure.in
parent56a004931238ccd47cd2102e8dc5f5f07df8d213 (diff)
* configure.in: fix "test: too many arguments" error.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@5319 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index e49b8d3bf5..1704619fec 100644
--- a/configure.in
+++ b/configure.in
@@ -684,13 +684,13 @@ int main()
], rb_cv_stack_grow_dir=-1, rb_cv_stack_grow_dir=+1, rb_cv_stack_grow_dir=0)])
AC_DEFINE_UNQUOTED(STACK_GROW_DIRECTION, $rb_cv_stack_grow_dir)
-if test "$enable_pthread" = "yes"; then
+if test x"$enable_pthread" = xyes; then
for pthread_lib in pthread pthreads c c_r; do
AC_CHECK_LIB($pthread_lib, pthread_kill,
rb_with_pthread=yes, rb_with_pthread=no)
if test "$rb_with_pthread" = "yes"; then break; fi
done
- if test $rb_with_pthread = yes; then
+ if test x"$rb_with_pthread" = xyes; then
AC_DEFINE(_REENTRANT)
AC_DEFINE(_THREAD_SAFE)
AC_DEFINE(HAVE_LIBPTHREAD)
@@ -708,15 +708,15 @@ if test "$enable_pthread" = "yes"; then
AC_MSG_WARN("Don't know how to find pthread library on your system -- thread support disabled")
fi
AC_CHECK_FUNC(nanosleep)
- if test "$ac_cv_func_nanosleep" = "no"; then
+ if test x"$ac_cv_func_nanosleep" = xno; then
AC_CHECK_LIB(rt, nanosleep)
- if test "$ac_cv_lib_rt_nanosleep" = "yes"; then
+ if test x"$ac_cv_lib_rt_nanosleep" = xyes; then
AC_DEFINE(HAVE_NANOSLEEP)
fi
fi
fi
-if test $ac_cv_header_ucontext_h = yes; then
- if test $target_cpu = ia64 -o $rb_with_pthread = yes; then
+if test x"$ac_cv_header_ucontext_h" = xyes; then
+ if test x"$target_cpu" = xia64 -o x"$rb_with_pthread" = xyes; then
AC_CHECK_FUNCS(getcontext setcontext)
fi
fi