summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2013-10-07 13:19:02 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2013-10-07 13:19:02 +0000
commit9e3eb502122cbc6433a50fc5b874ac759e0c5208 (patch)
tree8db5d53ebf9ddcbb168908e8646dbc542816d36c /configure.in
parent4549879579fb2eac72bd7e0be2330ce6b7551ff2 (diff)
configure.in: add mingw FIBER_USE_NATIVE
* configure.in (FIBER_USE_NATIVE): add mingw condition. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@43180 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 03d08386a1..04bdbb926c 100644
--- a/configure.in
+++ b/configure.in
@@ -2352,6 +2352,7 @@ if test x"$enable_pthread" = xyes; then
AC_CHECK_FUNCS(pthread_attr_init)
fi
fi
+FIBER_USE_NATIVE=0
if test x"$ac_cv_header_ucontext_h" = xyes; then
if test x"$rb_with_pthread" = xyes; then
AC_CHECK_FUNCS(getcontext setcontext)
@@ -2360,10 +2361,14 @@ if test x"$ac_cv_header_ucontext_h" = xyes; then
[*-netbsd*], [],
[ia64-*], [], # r38766
[*-sunos*|*-solaris*], [], # r32408
- [AC_DEFINE(FIBER_USE_NATIVE, 1)])
+ [FIBER_USE_NATIVE=1])
fi
fi
+else
+ AS_CASE("$target_os", [mingw*|mswin*],
+ [test "[$[with_winnt_ver]]" -ge [$[0x0400]] && FIBER_USE_NATIVE=1])
fi
+AC_DEFINE(FIBER_USE_NATIVE)
if test "$ac_cv_func_fork" = "yes" -a "$rb_with_pthread" = "yes"; then
AC_CACHE_CHECK([if fork works with pthread], rb_cv_fork_with_pthread,