summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-03-20 00:23:01 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-03-20 00:23:01 +0000
commit9bd7249fa50786e67b647b5410ef09dc8c5e6c73 (patch)
treead3f05e8e773b8c9e63c1944e15d81f1d45b864e /configure.in
parent835ad8b35cc9248ca1f2da67df3b24a10d944ce8 (diff)
* configure.in (libprefix): must not append "lib" after $(libdir),
when load_relative is not used on darwin. [ruby-dev:38182] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@23013 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 8309d537ee..2320703b46 100644
--- a/configure.in
+++ b/configure.in
@@ -1978,11 +1978,11 @@ if test "$enable_shared" = 'yes'; then
RUBY_SO_NAME="$RUBY_SO_NAME"'.$(MAJOR).$(MINOR).$(TEENY)'
LIBRUBY_LDSHARED='cc -dynamiclib -undefined suppress -flat_namespace'
if test "$load_relative" = yes; then
- libprefix='@executable_path/..'
+ libprefix='@executable_path/../lib'
else
libprefix='$(libdir)'
fi
- LIBRUBY_DLDFLAGS='-install_name '${libprefix}'/lib/lib$(RUBY_SO_NAME).dylib'
+ LIBRUBY_DLDFLAGS='-install_name '${libprefix}'/lib$(RUBY_SO_NAME).dylib'
LIBRUBY_DLDFLAGS="$LIBRUBY_DLDFLAGS "'-current_version $(MAJOR).$(MINOR).$(TEENY)'
LIBRUBY_DLDFLAGS="$LIBRUBY_DLDFLAGS "'-compatibility_version $(MAJOR).$(MINOR).$(TEENY)'
LIBRUBY_DLDFLAGS="$LIBRUBY_DLDFLAGS "'-Wl,-unexported_symbol,_Init_* $(XLDFLAGS)'