summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-04-25 09:21:49 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-04-25 09:21:49 +0000
commit9bb7a8ccddf15537da6af71e594322f2519350f7 (patch)
treeb3baff1e29bd6f902d015ba08e50e60fc6c2cccd /configure.in
parent0dae2c910fa646a2b41d33f0b4d1dad818eb00da (diff)
* configure.in (ac_cv_func_daemon): use daemon(3) only on *BSD.
* process.c (proc_daemon): double fork to ensure not having ctty. [ruby-core:23311] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@23277 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 127901f80a..fe99222ba4 100644
--- a/configure.in
+++ b/configure.in
@@ -728,6 +728,14 @@ AC_ARG_ENABLE(pthread,
dnl Checks for libraries.
case "$target_os" in
+when(*bsd*|dragonfly*)
+ ;;
+when(*)
+ ac_cv_func_daemon=no
+ ;;
+esac
+
+case "$target_os" in
when(nextstep*) ;;
when(openstep*) ;;
when(rhapsody*) ;;
@@ -744,7 +752,6 @@ when(darwin*) RUBY_PREPEND_OPTION(LIBS, -lobjc)
AC_MSG_RESULT($macosx_10_5)
if test $macosx_10_5 = yes; then
ac_cv_header_ucontext_h=no
- ac_cv_func_daemon=no
else
AC_DEFINE(BROKEN_SETREUID, 1)
AC_DEFINE(BROKEN_SETREGID, 1)