summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-11-27 10:09:11 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-11-27 10:09:11 +0000
commit9b58c2edf3dbb9adc4355e642e4124eeb47a43d5 (patch)
treeaaa9f82b6e598feb9cbdca1cd42169762a48ae9b /configure.in
parent41f756eaf3648156ad9645705bf843acdae73f2f (diff)
* configure.in (stack_protector): disable on mingw. [Bug#5676]
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@33870 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 9df6ad6bac..a57cec93a1 100644
--- a/configure.in
+++ b/configure.in
@@ -497,7 +497,13 @@ if test "$GCC:${warnflags+set}:no" = yes::no; then
fi
if test "$GCC" = yes; then
RUBY_TRY_CFLAGS(-D_FORTIFY_SOURCE=2, [RUBY_APPEND_OPTION(XCFLAGS, -D_FORTIFY_SOURCE=2)])
- RUBY_TRY_CFLAGS(-fstack-protector, [stack_protector=yes], [stack_protector=no])
+ AS_CASE(["$target_os"],
+ [mingw*], [
+ stack_protector=no
+ ],
+ [
+ RUBY_TRY_CFLAGS(-fstack-protector, [stack_protector=yes], [stack_protector=no])
+ ])
if test "x$stack_protector" = xyes; then
RUBY_APPEND_OPTION(XCFLAGS, -fstack-protector)
RUBY_APPEND_OPTION(XLDFLAGS, -fstack-protector)