summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-10-23 05:06:12 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-10-23 05:06:12 +0000
commit9a8d0e83c0bb5501185ecb3f080f448a908fc874 (patch)
tree9d4b428796fcda24ccd479e34dc87ea09732d95c /configure.in
parentd645c25a7f9fded298d17cde37705791c740d2a2 (diff)
* configure.in (optflags): removed -fomit-frame-pointer by default.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@25441 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 3a023fdf88..73b92995ba 100644
--- a/configure.in
+++ b/configure.in
@@ -266,7 +266,7 @@ AC_PROG_GCC_TRADITIONAL
AC_SUBST(GCC)
if test "$GCC" = yes; then
linker_flag=-Wl,
- : ${optflags='-O3 -fomit-frame-pointer'}
+ : ${optflags=-O3}
case "$target_os" in
when(linux*|darwin*)
: ${debugflags=-ggdb};;
@@ -1171,7 +1171,7 @@ test x$ac_cv_func__longjmp = xno && ac_cv_func__setjmp=no
AC_MSG_CHECKING(for setjmp type)
AC_ARG_WITH(setjmp-type,
- AS_HELP_STRING([--with-setjmp-type],[select setjmp type]),
+ AS_HELP_STRING([--with-setjmp-type], [select setjmp type]),
[
case $withval in
when(__builtin_setjmp) setjmp_prefix=__builtin_;;
@@ -2537,7 +2537,7 @@ fi
unset sitearch
case "$target_os" in
- when(mingw*) sitearch="$target_cpu-$rb_cv_msvcrt" ;;
+ when(mingw*) sitearch="$target_cpu-$rb_cv_msvcrt";;
esac
test ${sitearch+set} && AC_DEFINE_UNQUOTED(RUBY_SITEARCH, "${sitearch}")
@@ -2572,7 +2572,7 @@ AC_SUBST(sitehdrdir)dnl
AC_SUBST(vendorhdrdir)dnl
AC_ARG_WITH(mantype,
- AS_HELP_STRING([--with-mantype=TYPE], [specify man page type; TYPE is one of man and doc]),
+ AS_HELP_STRING([--with-mantype=TYPE], [specify man page type; TYPE is one of man and doc]),
[
case "$withval" in
when(man|doc)