summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2010-07-13 12:26:16 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2010-07-13 12:26:16 +0000
commit9a8440e5d46c67f9938b58d7491659d094c7c4b2 (patch)
treeab467130a6aed570a0a27eedfcfc3f5034edeb50 /configure.in
parent9afb0f0837976093225442c37283cdeacb573a29 (diff)
* configure.in: fix for universal binary.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@28628 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index e5c259f520..161e6ae083 100644
--- a/configure.in
+++ b/configure.in
@@ -284,7 +284,7 @@ AC_SUBST(COUTFLAG)
RUBY_MINGW32
RUBY_UNIVERSAL_ARCH
-if test "$target_cpu" != "$host_cpu" -a "$GCC" = yes -a "$cross_compiling" = no; then
+if test "$target_cpu" != "$host_cpu" -a "$GCC" = yes -a "$cross_compiling" = no -a "$universal_binary" = no; then
RUBY_DEFAULT_ARCH("$target_cpu")
fi