summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2010-06-26 04:07:20 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2010-06-26 04:07:20 +0000
commit967e3a3598143df7fdecbb3e1b7bf45789bd2211 (patch)
tree6e88d376fbd72a45d90a7eddc46e583cc2fbc298 /configure.in
parent8508e37b515804bb6774e79ab774ef7cc696c9cf (diff)
* configure.in (enable-debug-env): option for RUBY_DEBUG env.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@28446 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index a16a3d65b3..4098b34c3d 100644
--- a/configure.in
+++ b/configure.in
@@ -2277,6 +2277,10 @@ AS_CASE(["$THREAD_MODEL"],
[""], [AC_MSG_ERROR(thread model is missing)],
[AC_MSG_ERROR(unknown thread model $THREAD_MODEL)])
+AC_ARG_ENABLE(debug-env,
+ AS_HELP_STRING([--enable-debug-env], [enable RUBY_DEBUG environment variable]),
+ [AC_DEFINE(RUBY_DEBUG_ENV)])
+
AS_CASE(["$FIRSTMAKEFILE"], [*GNUmakefile:*], [gnumake=yes], [
AC_MSG_CHECKING([for if ${MAKE-make} is GNU make])
mkdir conftest.dir