summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-09-03 14:55:20 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-09-03 14:55:20 +0000
commit90a10297d685b12e691ddf0c04439d19f8592feb (patch)
treed0d615ccae68d4b2908dede442d0ee2cf4e37ae0 /configure.in
parent4ac511266dea82881bcf79ff29b7815a2d5e46ef (diff)
* configure.in (RUBY_MINGW32): take tool prefix from CC.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@33173 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 0bbc444201..616837d6ec 100644
--- a/configure.in
+++ b/configure.in
@@ -33,7 +33,10 @@ AC_CACHE_CHECK(for mingw32 environment, rb_cv_mingw32,
#endif
], rb_cv_mingw32=yes,rb_cv_mingw32=no)
rm -f conftest*])
-test "$rb_cv_mingw32" = yes && target_os="mingw32"
+if test "$rb_cv_mingw32" = yes; then
+ target_os="mingw32"
+ : ${ac_tool_prefix:="`expr "$CC" : ['\(.*-\)g\?cc[^/]*$']`"}
+fi
])
AS_CASE(["$target_os"], [mingw*msvc], [
target_os="`echo ${target_os} | sed 's/msvc$//'`"
@@ -280,6 +283,7 @@ fi
if test x"${build}" != x"${host}"; then
AC_CHECK_TOOL(CC, gcc)
fi
+RUBY_MINGW32
AC_PROG_CC
AC_PROG_CXX
AC_PROG_GCC_TRADITIONAL
@@ -302,7 +306,6 @@ RUBY_CPPOUTFILE
AC_SUBST(OUTFLAG)
AC_SUBST(COUTFLAG)
-RUBY_MINGW32
RUBY_UNIVERSAL_ARCH
if test "$target_cpu" != "$host_cpu" -a "$GCC" = yes -a "$cross_compiling" = no -a "$universal_binary" = no; then
RUBY_DEFAULT_ARCH("$target_cpu")