summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-11-25 20:00:31 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-11-25 20:00:31 +0000
commit8b83ea9ef1452e74f3a8b6e35000c83dd8b91fe7 (patch)
treec375e0ecea6608256d54b27522aa1310a2509c6d /configure.in
parentaa23f6b9fdecbf3be3e21b0f6b40e2b22f125090 (diff)
* configure.in (--no-undefined): RUBY_TRY_CFLAGS does nothing for
linker flags. use RUBY_TRY_LDFLAGS. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@33840 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 38e444e743..4b7fb581c9 100644
--- a/configure.in
+++ b/configure.in
@@ -2268,7 +2268,7 @@ AS_CASE("$enable_shared", [yes], [
fi
if test "$GCC" = yes; then
- RUBY_TRY_CFLAGS(-Xlinker --no-undefined, RUBY_APPEND_OPTION(EXTLDFLAGS, -Xlinker --no-undefined))
+ RUBY_TRY_LDFLAGS([-Xlinker --no-undefined], RUBY_APPEND_OPTION(EXTLDFLAGS, [-Xlinker --no-undefined]))
fi
AS_CASE(["$target_os"],