summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-08-12 08:29:56 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-08-12 08:29:56 +0000
commit89901cc760587bae5eabf97cea563b6c3cad7735 (patch)
treeeec9d92d4a512adc8141066cc96405c5aeca8aa2 /configure.in
parent3486904f4ed74687a6c86c1e2255bb733924283b (diff)
configure.in: [Bug #8409]
* configure.in: check if prefix is same as the cwd, not only same path name. also use AC_MSG_ERROR to bail out. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@47152 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index a2d0d81f00..530639f866 100644
--- a/configure.in
+++ b/configure.in
@@ -229,9 +229,8 @@ test -z "$CXX" || ac_cv_prog_CXX="$CXX"
if test "$program_prefix" = NONE; then
program_prefix=
fi
-if test "$prefix" = `pwd`; then
- echo "--prefix cannot be the current working directory."
- exit 1;
+if test "$prefix" -ef .; then
+ AC_MSG_ERROR(--prefix cannot be the current working directory.)
fi
RUBY_BASE_NAME=`echo ruby | sed "$program_transform_name"`
RUBYW_BASE_NAME=`echo rubyw | sed "$program_transform_name"`