summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-02-08 14:40:36 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-02-08 14:40:36 +0000
commit85b1671b4257332ade223d9e167cea0bf0d40fdf (patch)
treead27509ee94920b8e162ba260748dc8a84c6dde6 /configure.in
parentcd476cd86be581cca4ca56ad1277228ea1dc24ee (diff)
configure.in: Properly detect platform for SSE2 instructions.
* configure.in: add qouting brackets and append wildcard for the rest after target_cpu, to properly detect platform for SSE2 instructions. [ruby-core:60576] [Bug #8358] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@44890 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 4da41df606..609d797d76 100644
--- a/configure.in
+++ b/configure.in
@@ -864,7 +864,7 @@ if test "$GCC" = yes; then
[*-darwin*], [
# doesn't seem necessary on Mac OS X
],
- [i[4-6]86], [
+ [[i[4-6]86*]], [
RUBY_TRY_CFLAGS(-msse2 -mfpmath=sse, [
RUBY_APPEND_OPTION(XCFLAGS, -msse2 -mfpmath=sse)
RUBY_TRY_CFLAGS(-mstackrealign, [RUBY_APPEND_OPTION(XCFLAGS, -mstackrealign)])