summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2013-03-22 07:57:09 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2013-03-22 07:57:09 +0000
commit81cb1f63946ef5ba8847ac06019fc2d98a52c544 (patch)
tree1e9186f3c35f31ff4900488397855fd71ad89742 /configure.in
parente52a4a70a95e3d334608ab7534cda83b03512365 (diff)
compiler version
* common.mk (showflags): show the compiler version. * configure.in (CC_VERSION): compiler with version option. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@39873 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 06af58e8b5..599775ba65 100644
--- a/configure.in
+++ b/configure.in
@@ -422,6 +422,13 @@ RUBY_CPPOUTFILE
AC_SUBST(OUTFLAG)
AC_SUBST(COUTFLAG)
+cc_version_option=
+for option in --version -v -V -qversion; do
+ $CC $option > /dev/null 2>&1 || continue
+ cc_version='$(CC) '$option
+done
+AC_SUBST(CC_VERSION, $cc_version)
+
RUBY_UNIVERSAL_ARCH
if test "$target_cpu" != "$host_cpu" -a "$GCC" = yes -a "$cross_compiling" = no -a "$universal_binary" = no; then
RUBY_DEFAULT_ARCH("$target_cpu")