summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorkanemoto <kanemoto@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2010-05-15 17:25:33 +0000
committerkanemoto <kanemoto@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2010-05-15 17:25:33 +0000
commit8030f9c569d9c8952f8485979a4590c8252f9aab (patch)
treed17a0c9f9d5af1f297e42b2d25eec98d5c5fca7c /configure.in
parent91c24777b9b2653a7a2051288f333d271669e854 (diff)
* configure.in: can not load libruby.so if gcc is used with
--enable-shared on AIX. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_9_2@27803 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 2 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 98633bb526..4da4285bba 100644
--- a/configure.in
+++ b/configure.in
@@ -1813,11 +1813,7 @@ if test "$with_dln_a_out" != yes; then
LDFLAGS="${LDFLAGS:+$LDFLAGS }-L/usr/local/lib"
fi
rb_cv_dlopen=yes],
- [aix*], [ if test "$GCC" = yes; then
- : ${LDSHARED='$(CC) -shared'}
- else
- : ${LDSHARED='$(CC)'}
- fi
+ [aix*], [ : ${LDSHARED='$(CC)'}
LDSHARED="$LDSHARED ${linker_flag}-G"
DLDFLAGS='-eInit_$(TARGET)'
XLDFLAGS="${linker_flag}"'-bE:$(ARCHFILE)'" ${linker_flag}-brtl"
@@ -1826,7 +1822,7 @@ if test "$with_dln_a_out" != yes; then
TRY_LINK='$(CC) $(LDFLAGS) -oconftest $(INCFLAGS) -I$(hdrdir) $(CPPFLAGS)'
TRY_LINK="$TRY_LINK"' $(CFLAGS) $(src) $(LIBPATH) $(LOCAL_LIBS) $(LIBS)'
: ${LIBPATHENV=SHLIB_PATH}
- RPATHFLAG=" ${linker_flag}-blibpath:%1\$-s:${LIBPATH:-/usr/lib:/lib}"
+ RPATHFLAG=" ${linker_flag}-blibpath:%1\$-s:${prefix}/lib:${LIBPATH:-/usr/lib:/lib}"
rb_cv_dlopen=yes],
[human*], [ : ${DLDFLAGS=''}
: ${LDSHARED=''}