summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornormal <normal@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2017-04-22 01:08:15 +0000
committernormal <normal@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2017-04-22 01:08:15 +0000
commit7e5462b36f0e3c07b3bdfcb09970fe39010c923e (patch)
tree1d55e560fd73eeccf6fc4b3735ce8031a42f73bc /configure.in
parent966bfb07f6a7d1480abf8e48688294716218b72e (diff)
define PACKED_STRUCT_UNALIGNED correctly
Defining PACKED_STRUCT_UNALIGNED to a noop in ruby/config.h (via `configure') prevents the definition in include/ruby/defines.h from working This should have been fixed in r46914, so there's a size regression for some objects since Ruby 2.2+. I do not believe we can backport to existing releases, either, since it can affect ABI. Add a test for Time objects on common x86-based platforms to check for future regressions. * configure.in: remove PACKED_STRUCT_UNALIGNED definition * test/ruby/test_time.rb (test_memsize): new test for x86 git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@58442 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 0 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index dedde6d83f..a2b0a5b916 100644
--- a/configure.in
+++ b/configure.in
@@ -1642,13 +1642,11 @@ AC_CACHE_CHECK(packed struct attribute, rb_cv_packed_struct,
PACKED_STRUCT(struct { int a; });], [],
[rb_cv_packed_struct=$mac; break])
done])
-packed_struct_unaligned=x
if test "$rb_cv_packed_struct" != no; then
AC_DEFINE_UNQUOTED([PACKED_STRUCT(x)], [$rb_cv_packed_struct])
else
AC_DEFINE_UNQUOTED([PACKED_STRUCT(x)], x)
fi
-AC_DEFINE_UNQUOTED(PACKED_STRUCT_UNALIGNED(x), $packed_struct_unaligned)
AC_DEFUN([RUBY_CHECK_PRINTF_PREFIX], [
AC_CACHE_CHECK([for printf prefix for $1], [rb_cv_pri_prefix_]AS_TR_SH($1),[