summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2004-12-22 15:16:55 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2004-12-22 15:16:55 +0000
commit7d6f48ccd22e93b6213514962a6ded168cad2966 (patch)
treedb0a737271076e8b4fdc8af2a1a0a459895c6df3 /configure.in
parentf68ab9c2d9a2208a5f8039db6bc35a9fa5c707ee (diff)
* configure.in (bsdi): use $(CC) for LDSHARED. fixed [ruby-dev:25270]
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@7636 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 6 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 04ec31b72c..fb28044117 100644
--- a/configure.in
+++ b/configure.in
@@ -779,7 +779,7 @@ if test "$rb_cv_binary_elf" = yes; then
fi
case "$target_os" in
-linux* | gnu* | k*bsd*-gnu)
+linux* | gnu* | k*bsd*-gnu | bsdi*)
if test "$rb_cv_binary_elf" = no; then
with_dln_a_out=yes
else
@@ -852,7 +852,11 @@ if test "$with_dln_a_out" != yes; then
rb_cv_dlopen=yes ;;
osf*) : ${LDSHARED="ld -shared -expect_unresolved \"*\""}
rb_cv_dlopen=yes ;;
- linux* | gnu* | k*bsd*-gnu | netbsd*)
+ bsdi3*) case "$CC" in
+ *shlicc*) : ${LDSHARED="$CC -r"}
+ rb_cv_dlopen=yes ;;
+ esac ;;
+ linux* | gnu* | k*bsd*-gnu | netbsd* | bsdi*)
: ${LDSHARED='${CC} -shared'}
if test "$rb_cv_binary_elf" = yes; then
LDFLAGS="$LDFLAGS -Wl,-export-dynamic"
@@ -875,13 +879,6 @@ if test "$with_dln_a_out" != yes; then
LDFLAGS="$LDFLAGS -Wl,-E"
fi
rb_cv_dlopen=yes ;;
- bsdi3*) case "$CC" in
- *shlicc*) : ${LDSHARED="$CC -r"}
- rb_cv_dlopen=yes ;;
- esac ;;
- bsdi*) : ${LDSHARED="ld -shared"}
- LDFLAGS="$LDFLAGS "'-rdynamic -Wl,-rpath,$(libdir)/ruby/$(MAJOR).$(MINOR)/i386-bsdi4.0'
- rb_cv_dlopen=yes ;;
nextstep*) : ${LDSHARED='cc -r -nostdlib'}
LDFLAGS="$LDFLAGS -u libsys_s"
rb_cv_dlopen=yes ;;