summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-04-18 13:59:00 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-04-18 13:59:00 +0000
commit7cfc4be29850673034fd2d121dcf6fb4d9892bdb (patch)
tree5467f58447f00e4aa4c68115864029ed88eed2f1 /configure.in
parent336cf57584dd8c055325da950c3f7c45dd8c1345 (diff)
* configure.in (DOT, DOXYGEN): use AC_CHECK_PROGS instead of
AC_CHECK_PROG which needs the third argument. [ruby-core:44433] [Bug #6316] * configure.in (PKG_CONFIG): fix condition to skip older version of pkg-config. continue in backticks does not affect outside. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@35387 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index a0dd303406..2df023b57d 100644
--- a/configure.in
+++ b/configure.in
@@ -368,11 +368,11 @@ fi
MAKEDIRS="$MKDIR_P"
AC_SUBST(MAKEDIRS)
-AC_CHECK_PROG(DOT, dot)
-AC_CHECK_PROG(DOXYGEN, doxygen)
+AC_CHECK_PROGS(DOT, dot)
+AC_CHECK_PROGS(DOXYGEN, doxygen)
-AC_CHECK_PROG(PKG_CONFIG, pkg-config, [], [], [],
- [`$as_dir/$ac_word$ac_exec_ext --print-errors --version > /dev/null 2>&1 || continue`])
+AC_CHECK_PROG(PKG_CONFIG, pkg-config, [pkg-config], [], [],
+ [`"$as_dir/$ac_word$ac_exec_ext" --print-errors --version > /dev/null 2>&1 || echo "$as_dir/$ac_word$ac_exec_ext"`])
# checks for UNIX variants that set C preprocessor variables
AC_USE_SYSTEM_EXTENSIONS