summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2013-03-26 20:15:44 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2013-03-26 20:15:44 +0000
commit7b2c7b620c9d124d5d676a09acf6799f57627b0d (patch)
treedd77469f1817823d1a883ee019c0076c01a4f132 /configure.in
parent5426842df30fcf2d3251e9235bfb54d7c848602f (diff)
internal.h: use SIGNEDNESS_OF_TIME_T
* configure.in (RUBY_REPLACE_TYPE): define SIGNEDNESS_OF_type same as check_signedness of mkmf.rb. * internal.h (TIMET_MAX, TIMET_MIN, TIMET_MAX_PLUS_ONE): use SIGNEDNESS_OF_TIME_T. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@39956 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 599775ba65..baa77f371f 100644
--- a/configure.in
+++ b/configure.in
@@ -1171,7 +1171,9 @@ AC_DEFUN([RUBY_REPLACE_TYPE], [dnl
t=INT])
rb_cv_[$1]_convertible=${u}${t}])
test "${AS_TR_SH(ac_cv_type_[$1])}" = "yes" && n="$1"
+ AS_CASE("${rb_cv_[$1]_convertible}", [U*], [u=+1], [u=-1])
AC_DEFINE_UNQUOTED(rb_[$1], $n)
+ AC_DEFINE_UNQUOTED([SIGNEDNESS_OF_]AS_TR_CPP($1), $u)
AC_DEFINE_UNQUOTED([$3]2NUM[(v)], [${rb_cv_[$1]_convertible}2NUM(v)])
AC_DEFINE_UNQUOTED(NUM2[$3][(v)], [NUM2${rb_cv_[$1]_convertible}(v)])
AC_DEFINE_UNQUOTED(PRI_[$3]_PREFIX,