summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-08-03 06:21:16 +0000
committernaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-08-03 06:21:16 +0000
commit77ef86feaa7218500435c0851701e8a4688fa82a (patch)
tree0a3c0aab6b83dc59c8c3d639afb2c2b54214e331 /configure.in
parente25baf1d6264d07f8c313b3982f2249bf436e94e (diff)
* configure.in: move RUBY_MINGW32 after AC_PROG_CC.
RUBY_MINGW32 uses AC_TRY_CPP and it sets CC and CPP. [Bug #6816] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@36603 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index fad36e09d9..0ebb7cbdbd 100644
--- a/configure.in
+++ b/configure.in
@@ -372,11 +372,11 @@ RUBY_NACL
if test x"${build}" != x"${host}"; then
AC_CHECK_TOOL(CC, gcc)
fi
-RUBY_MINGW32
AS_CASE(["$build_os"],
[darwin*], [ AC_PROG_CC(clang gcc cc) ],
[ AC_PROG_CC ])
AC_PROG_CXX
+RUBY_MINGW32
AC_PROG_GCC_TRADITIONAL
AC_SUBST(GCC)
AC_CHECK_TOOL([LD], [ld], [ld])