summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-05-17 14:04:02 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-05-17 14:04:02 +0000
commit7788d102c9fe6f58ec9413009374ffeb6b58c84f (patch)
treed9afdc4c50800ea23746704facb2d1659edcc7ab /configure.in
parent315a0cb926ab5a4654a4e0a84eb600512e9960a3 (diff)
fix NaCl support
* configure.in: fix function name to be checked, to initialize rb_thread_cond_t properly. * thread_pthread.c (native_cond_initialize, native_cond_destroy): fix macro name. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@35676 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 24e650ba8d..3e157cacda 100644
--- a/configure.in
+++ b/configure.in
@@ -2005,7 +2005,7 @@ if test x"$enable_pthread" = xyes; then
pthread_getattr_np pthread_attr_get_np pthread_attr_getstack\
pthread_get_stackaddr_np pthread_get_stacksize_np \
thr_stksegment pthread_stackseg_np pthread_getthrds_np \
- pthread_cond_initialize pthread_condattr_setclock pthread_condattr_init \
+ pthread_cond_init pthread_condattr_setclock pthread_condattr_init \
pthread_sigmask)
fi
if test x"$ac_cv_header_ucontext_h" = xyes; then