summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-08-20 22:14:58 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-08-20 22:14:58 +0000
commit7439c06ab7d1adc1ffce82ff39ba60ee78dd0996 (patch)
tree4f649a8ee19edbfd86a66384a6cc400efa5c1e62 /configure.in
parente22b92dce4dc7723cf95849edf9beb7126c63960 (diff)
* configure.in (RUBY_PROGRAM_VERSION, RUBY_RELEASE_DATE): extracts
from version.h for cross-compiling. * template/fake.rb.in (RUBY_VERSION, RUBY_DESCRIPTION): use above. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@24602 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 1e32b7db9c..005a2e30b0 100644
--- a/configure.in
+++ b/configure.in
@@ -84,6 +84,10 @@ done
AC_SUBST(MAJOR)
AC_SUBST(MINOR)
AC_SUBST(TEENY)
+RUBY_PROGRAM_VERSION=`sed -n 's/^#define RUBY_VERSION "\(.*\)"/\1/p' $srcdir/version.h`
+AC_SUBST(RUBY_PROGRAM_VERSION)
+RUBY_RELEASE_DATE=`sed -n 's/^#define RUBY_RELEASE_DATE "\(.*\)"/\1/p' $srcdir/version.h`
+AC_SUBST(RUBY_RELEASE_DATE)
if test "$MAJOR" = "1"; then
AC_DEFINE(CANONICALIZATION_FOR_MATHN)
fi