summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorkanemoto <kanemoto@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-03-26 00:13:36 +0000
committerkanemoto <kanemoto@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-03-26 00:13:36 +0000
commit738c3034610be758d9758398846f9ff7eea2a4a8 (patch)
tree6838371bde185c2b72ce0a2da87cb633a8adc98e /configure.in
parent537623e43de8b5659e011a7418b23bfd56645b20 (diff)
add --disable-pie option to configure
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@45419 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 55dea5123e..3845f05c7c 100644
--- a/configure.in
+++ b/configure.in
@@ -3275,7 +3275,9 @@ AS_CASE("$enable_shared", [yes], [
LIBRUBYARG_SHARED=
# enable PIE if possible
- pie=
+ AC_ARG_ENABLE(pie,
+ AS_HELP_STRING([--disable-pie], [disable PIE feature]),
+ [pie=$enableval], [pie=])
AS_CASE(["$target_os"],
[haiku], [
# gcc supports PIE, but doesn't work correctly in Haiku