summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2013-08-09 13:51:13 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2013-08-09 13:51:13 +0000
commit6e563a4eccdd10eb107aa1f7ac7a4ff61383f1a8 (patch)
treebe9f356aed7414d780e6a995622971ae57956650 /configure.in
parent23f039f3b39f4eab3e23477b8e4f48d40671b9a2 (diff)
configure.in: CoreFoundation framework option
* configure.in (XLDFLAGS, LIBRUBYARG_STATIC): CoreFoundation framework option is now needed always, regardless enable-shared. [ruby-core:56467] [Bug #8759] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@42472 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 0302d29f2c..bd3758c46f 100644
--- a/configure.in
+++ b/configure.in
@@ -3060,8 +3060,6 @@ AS_CASE("$enable_shared", [yes], [
LIBRUBY_DLDFLAGS="$LIBRUBY_DLDFLAGS "' $(XLDFLAGS)'
LIBRUBY_SO='lib$(RUBY_SO_NAME).dylib'
LIBRUBY_ALIASES='lib$(RUBY_BASE_NAME).$(MAJOR).$(MINOR).dylib lib$(RUBY_INSTALL_NAME).dylib'
- RUBY_APPEND_OPTION(XLDFLAGS, [-framework CoreFoundation])
- RUBY_APPEND_OPTION(LIBRUBYARG_STATIC, [-framework CoreFoundation])
],
[interix*], [
LIBRUBYARG_SHARED='-L. -L${libdir} -l$(RUBY_SO_NAME)'
@@ -3235,6 +3233,8 @@ AS_CASE(["$target_os"],
],
[darwin*], [
RUBY_APPEND_OPTION(CFLAGS, -pipe)
+ RUBY_APPEND_OPTION(XLDFLAGS, [-framework CoreFoundation])
+ RUBY_APPEND_OPTION(LIBRUBYARG_STATIC, [-framework CoreFoundation])
],
[os2-emx], [
AC_LIBOBJ([os2])