summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-03-23 00:56:46 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-03-23 00:56:46 +0000
commit6d8580fe254d24b3868fb558ada142cd36242d63 (patch)
treeff9417c7bae34d1c838228336c0a6b457dce3dda /configure.in
parente91983b471246104ade82a4257b71a77107b6921 (diff)
* configure.in (Makefile): get rid of confliction with -j.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@35115 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 17 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 103b0f5b11..8c5cc7576d 100644
--- a/configure.in
+++ b/configure.in
@@ -3050,7 +3050,9 @@ AC_MSG_RESULT($PACKAGE library version = $ruby_version)
AS_CASE([" $CPP "], [*" $CC "*], [CPP=`echo " $CPP " | sed "s| $CC |"' $(CC) |;s/^ *//;s/ *$//'`])
AC_CONFIG_FILES($FIRSTMAKEFILE)
-AC_CONFIG_FILES(Makefile, [{
+AC_CONFIG_FILES(Makefile, [
+ tmpmk=confmk$$.tmp
+ {
if test ${VCS+set}; then
:
elif svn info "$srcdir" > /dev/null 2>&1; then
@@ -3075,12 +3077,20 @@ AC_CONFIG_FILES(Makefile, [{
else
echo 'distclean-local::; @$(RM) GNUmakefile uncommon.mk'
fi
- } > confmk$$.tmp && mv -f confmk$$.tmp Makefile &&
- {
- grep '^ruby:' Makefile > /dev/null ||
- ${MAKE-make} info-program | grep '^PROGRAM=ruby$' > /dev/null ||
- echo 'ruby: $(PROGRAM);' >> Makefile
- }],
+ } > $tmpmk && if ! grep '^ruby:' $tmpmk > /dev/null; then
+ if test "${gnumake}" = yes; then
+ tmpgmk=confgmk$$.tmp
+ {
+ echo "include $tmpmk"
+ echo "-include uncommon.mk"
+ } > $tmpgmk
+ else
+ tmpgmk=$tmpmk
+ fi &&
+ test -z "`${MAKE-make} -f $tmpgmk info-program | grep '^PROGRAM=ruby$'`" &&
+ echo 'ruby: $(PROGRAM);' >> $tmpmk
+ test "$tmpmk" = "$tmpgmk" || rm -f "$tmpgmk"
+ fi && mv -f $tmpmk Makefile],
[EXEEXT='$EXEEXT' gnumake='$gnumake'])
AC_ARG_WITH([ruby-pc],