summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorakr <akr@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2013-05-10 10:33:18 +0000
committerakr <akr@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2013-05-10 10:33:18 +0000
commit695ad02d1bf0fe00c188d50d4c81af0ad3fa2087 (patch)
treed00e659d1352b1c2ca4a8dcff43143e14be3a98c /configure.in
parent093beeda90631de7c1d82abb1be4ef0f7bde06c2 (diff)
* configure.in: Reformat arguments of AC_CHECK_HEADERS and
AC_CHECK_FUNCS to track modifications easily. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@40632 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in159
1 files changed, 138 insertions, 21 deletions
diff --git a/configure.in b/configure.in
index 355d2cf748..91eb7dad91 100644
--- a/configure.in
+++ b/configure.in
@@ -994,12 +994,40 @@ AC_HEADER_DIRENT
dnl AC_HEADER_STDC has been checked in AC_USE_SYSTEM_EXTENSIONS
AC_HEADER_STDBOOL
AC_HEADER_SYS_WAIT
-AC_CHECK_HEADERS(limits.h sys/file.h sys/ioctl.h sys/syscall.h\
- fcntl.h sys/fcntl.h sys/select.h sys/time.h sys/times.h sys/param.h\
- syscall.h pwd.h grp.h a.out.h utime.h direct.h sys/resource.h \
- sys/mkdev.h sys/utime.h float.h ieeefp.h \
- ucontext.h intrinsics.h langinfo.h locale.h sys/sendfile.h time.h \
- net/socket.h sys/socket.h process.h sys/prctl.h atomic.h)
+AC_CHECK_HEADERS( \
+ limits.h \
+ sys/file.h \
+ sys/ioctl.h \
+ sys/syscall.h \
+ fcntl.h \
+ sys/fcntl.h \
+ sys/select.h \
+ sys/time.h \
+ sys/times.h \
+ sys/param.h \
+ syscall.h \
+ pwd.h \
+ grp.h \
+ a.out.h \
+ utime.h \
+ direct.h \
+ sys/resource.h \
+ sys/mkdev.h \
+ sys/utime.h \
+ float.h \
+ ieeefp.h \
+ ucontext.h \
+ intrinsics.h \
+ langinfo.h \
+ locale.h \
+ sys/sendfile.h \
+ time.h \
+ net/socket.h \
+ sys/socket.h \
+ process.h \
+ sys/prctl.h \
+ atomic.h \
+)
dnl check for large file stuff
mv confdefs.h confdefs1.h
@@ -1702,21 +1730,110 @@ if test x"$ac_cv_func_clock_gettime" != xyes; then
AC_CHECK_FUNCS(clock_gettime)
fi
-AC_CHECK_FUNCS(fmod killpg wait4 waitpid fork spawnv syscall __syscall chroot getcwd eaccess\
- truncate ftruncate ftello chsize times utimes utimensat fcntl lockf lstat\
- truncate64 ftruncate64 ftello64 fseeko fseeko64 \
- link symlink readlink readdir_r fsync fdatasync fchown posix_fadvise\
- setitimer setruid seteuid setreuid setresuid\
- setrgid setegid setregid setresgid issetugid pause lchown lchmod\
- getpgrp setpgrp getpgid setpgid initgroups getgroups setgroups\
- getpriority getrlimit setrlimit sysconf close \
- getpwnam_r getgrnam_r endgrent \
- dlopen sigprocmask sigaction _setjmp _longjmp\
- getsid setsid telldir seekdir fchmod cosh sinh tanh log2 round llabs\
- setuid setgid daemon select_large_fdset setenv unsetenv\
- mktime timegm gmtime_r gettimeofday poll ppoll\
- pread sendfile shutdown sigaltstack dl_iterate_phdr\
- dup dup3 pipe2 posix_memalign memalign ioctl mblen)
+AC_CHECK_FUNCS( \
+ fmod \
+ killpg \
+ wait4 \
+ waitpid \
+ fork \
+ spawnv \
+ syscall \
+ __syscall \
+ chroot \
+ getcwd \
+ eaccess \
+ truncate \
+ ftruncate \
+ ftello \
+ chsize \
+ times \
+ utimes \
+ utimensat \
+ fcntl \
+ lockf \
+ lstat \
+ truncate64 \
+ ftruncate64 \
+ ftello64 \
+ fseeko \
+ fseeko64 \
+ link \
+ symlink \
+ readlink \
+ readdir_r \
+ fsync \
+ fdatasync \
+ fchown \
+ posix_fadvise \
+ setitimer \
+ setruid \
+ seteuid \
+ setreuid \
+ setresuid \
+ setrgid \
+ setegid \
+ setregid \
+ setresgid \
+ issetugid \
+ pause \
+ lchown \
+ lchmod \
+ getpgrp \
+ setpgrp \
+ getpgid \
+ setpgid \
+ initgroups \
+ getgroups \
+ setgroups \
+ getpriority \
+ getrlimit \
+ setrlimit \
+ sysconf \
+ close \
+ getpwnam_r \
+ getgrnam_r \
+ endgrent \
+ dlopen \
+ sigprocmask \
+ sigaction \
+ _setjmp \
+ _longjmp \
+ getsid \
+ setsid \
+ telldir \
+ seekdir \
+ fchmod \
+ cosh \
+ sinh \
+ tanh \
+ log2 \
+ round \
+ llabs \
+ setuid \
+ setgid \
+ daemon \
+ select_large_fdset \
+ setenv \
+ unsetenv \
+ mktime \
+ timegm \
+ gmtime_r \
+ gettimeofday \
+ poll \
+ ppoll \
+ pread \
+ sendfile \
+ shutdown \
+ sigaltstack \
+ dl_iterate_phdr \
+ dup \
+ dup3 \
+ pipe2 \
+ posix_memalign \
+ memalign \
+ ioctl \
+ mblen \
+)
AC_CACHE_CHECK(for sigsetjmp as a macro or function, ac_cv_func_sigsetjmp,
[AC_TRY_COMPILE([