summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-08-25 14:33:11 +0000
committernaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-08-25 14:33:11 +0000
commit649f648ec1ebc166dc37aeed7c0be50e8bfd85d2 (patch)
treea4226461404da7421ce1a5cf7d31d1e649a75381 /configure.in
parent0fd1688bf5acd207a81a1600eb0b43a7a059e356 (diff)
Fix for Linux compatibility
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@24650 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 7 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 86692b8628..bc0a2c0e20 100644
--- a/configure.in
+++ b/configure.in
@@ -309,12 +309,13 @@ AC_PROG_LN_S
AC_PROG_MAKE_SET
AC_PROG_INSTALL
AC_PROG_MKDIR_P
-if test "x$MKDIR_P" != "x -d"; then
-elif test x"$as_mkdir_p" != xfalse; then
- MKDIR_P='mkdir -p'
- echo "use 'mkdir -p' as MKDIR_P"
-else
- AC_MSG_ERROR([mkdir -p is required])
+if test "x$MKDIR_P" = "x -d"; then
+ if test x"$as_mkdir_p" != xfalse; then
+ MKDIR_P='mkdir -p'
+ echo "use 'mkdir -p' as MKDIR_P"
+ else
+ AC_MSG_ERROR([mkdir -p is required])
+ fi
fi
MAKEDIRS="$MKDIR_P"
AC_SUBST(MAKEDIRS)