summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-06-13 04:09:37 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-06-13 04:09:37 +0000
commit6379978d453a910ad672f3def32b869a6cfa108c (patch)
tree22e260ff044721a98b8f97e63ea1cf23ef782448 /configure.in
parent9341988b4141534586c24d60265d45292dc8d505 (diff)
configure.in: check iff nacl
* configure.in (RUBY_NACL_CHECK_PEPPER_TYPES): check only on nacl. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@36053 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 1d8fed5810..8c50ef511e 100644
--- a/configure.in
+++ b/configure.in
@@ -125,12 +125,14 @@ AC_DEFUN([RUBY_NACL],
])])
AC_DEFUN([RUBY_NACL_CHECK_PEPPER_TYPES],
-[
+[AS_CASE(["${host_os}"],
+[nacl], [
AC_CHECK_TYPES([struct PPB_Core, struct PPB_Messaging, struct PPB_Var,
struct PPB_URLLoader, struct PPB_URLRequestInfo,
struct PPB_URLResponseInfo, struct PPB_FileRef,
struct PPP_Instance])
])
+])
AC_DEFUN([RUBY_CPPOUTFILE],
[AC_CACHE_CHECK(whether ${CPP} accepts -o, rb_cv_cppoutfile,