summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-05-16 00:03:31 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-05-16 00:03:31 +0000
commit60a5a54e17e274daa6c6c8d2282ee0148ff6b6ec (patch)
tree5c86fe13784092d3af0f07a5869a640f8fedc124 /configure.in
parent62e5fa173788a443ad230eb379905515cad04a87 (diff)
* configure.in (ruby_version): now version.h includes
include/ruby/version.h, so need to tell to cpp to see $(srcdir)/include. [ruby-core:23468] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@23434 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index b63c677179..3680a2d107 100644
--- a/configure.in
+++ b/configure.in
@@ -2317,7 +2317,7 @@ if test ${RUBY_LIB_VERSION_STYLE+set}; then
echo '#include "version.h"'
echo 'ruby_version=RUBY_LIB_VERSION'
} > conftest.c
- ruby_version="`$CPP -I"${srcdir}" conftest.c | sed '/^ruby_version=/!d;s/ //g'`"
+ ruby_version="`$CPP -I"${srcdir}" -I"${srcdir}/include" conftest.c | sed '/^ruby_version=/!d;s/ //g'`"
eval $ruby_version
else
RUBY_LIB_VERSION="\"${ruby_version}\""