summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2016-10-22 01:27:04 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2016-10-22 01:27:04 +0000
commit5ccf58eb3254ee78fe7904155467b658cf0b6b0d (patch)
tree45c966619369d3603c04125d85313d908a7c54e0 /configure.in
parentf0f3f225b8a9868763746954665477c479275a5d (diff)
configure.in: fix RUBY_{APPEND/PREPEND}_OPTION
* configure.in (RUBY_APPEND_OPTION, RUBY_PREPEND_OPTION): expand the option to be appended/prepended when matching, as well as RUBY_APPEND_OPTIONS and RUBY_PREPEND_OPTIONS. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@56471 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 8dd3aa9e66..9d355e1250 100644
--- a/configure.in
+++ b/configure.in
@@ -311,7 +311,7 @@ AS_IF([test -z "$target_alias" -a -n "$os_version_style_transform"],
AC_DEFUN([RUBY_APPEND_OPTION],
[# RUBY_APPEND_OPTION($1)
AS_CASE([" [$]{$1-} "],
- [*' $2 '*], [], [' '], [ $1="$2"], [ $1="[$]$1 $2"])])
+ [*" $2 "*], [], [' '], [ $1="$2"], [ $1="[$]$1 $2"])])
AC_DEFUN([RUBY_APPEND_OPTIONS],
[# RUBY_APPEND_OPTIONS($1)
for rb_opt in $2; do
@@ -321,7 +321,7 @@ AC_DEFUN([RUBY_APPEND_OPTIONS],
AC_DEFUN([RUBY_PREPEND_OPTION],
[# RUBY_PREPEND_OPTION($1)
AS_CASE([" [$]{$1-} "],
- [*' $2 '*], [], [' '], [ $1="$2"], [ $1="$2 [$]$1"])])
+ [*" $2 "*], [], [' '], [ $1="$2"], [ $1="$2 [$]$1"])])
AC_DEFUN([RUBY_PREPEND_OPTIONS],
[# RUBY_PREPEND_OPTIONS($1)
unset rb_opts; for rb_opt in $2; do