summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-06-10 05:28:51 +0000
committernaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-06-10 05:28:51 +0000
commit5c45a1373aa595d65ce796a24980c9804e58d8ec (patch)
treec15d5e870df71bbc5fc3975187e888fbcccf48ea /configure.in
parentc39fd4c34056fbebafc5ccfb3d63612538d3f234 (diff)
* configure.in: NetBSD 6 adds libexecinfo but it only works on amd64.
http://www.mail-archive.com/source-changes-full@netbsd.org/msg38729.html git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@36010 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 030b79e3c9..973445f56f 100644
--- a/configure.in
+++ b/configure.in
@@ -2079,14 +2079,19 @@ main(int argc, char *argv[])
test x$rb_cv_fork_with_pthread = xyes || AC_DEFINE(CANNOT_FORK_WITH_PTHREAD)
fi
-AS_CASE(["$target_os"],
-[freebsd*], [
+AS_CASE(["$target_cpu-$target_os"],
+[*-freebsd*], [
AC_CHECK_HEADERS([/usr/local/include/execinfo.h])
if test "x$ac_cv_header__usr_local_include_execinfo_h" = xyes; then :
RUBY_APPEND_OPTION(CPPFLAGS, -I/usr/local/include)
LDFLAGS="${LDFLAGS:+$LDFLAGS }-L/usr/local/lib"
DLDFLAGS="${DLDFLAGS:+$DLDFLAGS }-L/usr/local/lib"
AC_CHECK_LIB([execinfo], [backtrace])
+ fi],
+[x86_64-netbsd*], [
+ AC_CHECK_HEADERS([execinfo.h])
+ if test "x$ac_cv_header_execinfo_h" = xyes; then :
+ AC_CHECK_LIB([execinfo], [backtrace])
fi])
AC_CHECK_FUNCS(backtrace)