summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2013-02-25 04:12:45 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2013-02-25 04:12:45 +0000
commit5919370363cd39a04bb3e848b1e15f9c2f1b3ce3 (patch)
tree020015f42998be6fcf326ec70a8060e4a8e478cf /configure.in
parenteed06bb0434c6c1f94513e22b4ad4f89bcec0d8b (diff)
configure.in: find Setup file automatically
* configure.in (setup): find Setup file from target_os 1. by suffix (e.g. Setup.nacl, Setup.atheos), 2. by "platform" option (e.g. Setup.nt, Setup.emx), and 3. default Setup. And Setup.dj had been removed. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@39486 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in31
1 files changed, 16 insertions, 15 deletions
diff --git a/configure.in b/configure.in
index 5fdac50fdc..c3477a3108 100644
--- a/configure.in
+++ b/configure.in
@@ -2580,21 +2580,22 @@ fi
AC_SUBST(ENCOBJS)
AC_SUBST(EXTOBJS)
-AS_CASE(["$target_os"],
- dnl OS/2 environment w/ Autoconf 2.1x for EMX
- [os2-emx], [
- setup=Setup.emx
- ],
- [*djgpp*], [
- setup=Setup.dj
- ],
- [nacl], [
- setup=Setup.nacl
- ],
- [
- setup=Setup
- ])
-
+if test -f "$srcdir/ext/Setup.$target_os"; then
+ setup="Setup.$target_os"
+else
+ setup=
+ for file in "$srcdir"/ext/Setup.*; do
+ AS_CASE(["$file"], [*~|*.bak|*.orig|*.rej|*.tmp], [continue])
+ setup=`basename "$file"`
+ AS_CASE(["$target_os"], [`expr "$setup" : 'Setup.\(.*\)'`*], [break])
+ platform=`sed '/^option *platform */!d;s///;s/|/*|/g;q' "$file"`
+ if test "x$platform" != x; then
+ eval "AS_CASE([\"\$target_os\"], [$platform*], [break])"
+ fi
+ setup=
+ done
+ : ${setup:=Setup}
+fi
AC_SUBST(setup)
test x"$prefix" = xNONE && prefix=$ac_default_prefix