summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormrkn <mrkn@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2010-04-14 09:29:29 +0000
committermrkn <mrkn@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2010-04-14 09:29:29 +0000
commit55f7857a7758102eb512eaa7aca3d2855fb797da (patch)
tree4117b788a9b2f31127428be1f113b84341f3247b /configure.in
parent8e7a682be04ac9060f1957ea12a84d2aeb7374c9 (diff)
* configure.in (signbit): signbit is a macro in C99.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@27341 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index fe7f8d2d32..e9116497c4 100644
--- a/configure.in
+++ b/configure.in
@@ -1116,8 +1116,19 @@ AS_CASE([$rb_cv_broken_glibc_ia64_erfc],[yes],[ac_cv_func_erf=no])
AC_REPLACE_FUNCS(dup2 memmove strerror\
strchr strstr crypt flock\
- isnan finite isinf hypot acosh erf tgamma lgamma_r cbrt signbit \
+ isnan finite isinf hypot acosh erf tgamma lgamma_r cbrt \
strlcpy strlcat)
+AC_CACHE_CHECK(for signbit, rb_cv_have_signbit,
+ [AC_TRY_COMPILE([
+#include <math.h>
+], [int v = signbit(-0.0);],
+ rb_cv_have_signbit=yes,
+ rb_cv_have_signbit=no)])
+if test "$rb_cv_have_signbit" = yes; then
+ AC_DEFINE(HAVE_SIGNBIT)
+else
+ AC_LIBOBJ([signbit])
+fi
AC_CHECK_FUNCS(fmod killpg wait4 waitpid fork spawnv syscall chroot getcwd eaccess\
truncate ftruncate chsize times utimes utimensat fcntl lockf lstat\
link symlink readlink readdir_r fsync fdatasync\