summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2010-11-12 07:54:27 +0000
committernaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2010-11-12 07:54:27 +0000
commit54ba50918e6ebb38ce36a7cfce7751855d86c947 (patch)
tree0f645f05e1bcc600d880b5fb692984187816616f /configure.in
parent7b109f17728f4a02a3cc7f3dd7de8a40c296ba09 (diff)
* configure.in: support C level backtrace information on FreeBSD.
When devel/libexecinfo is installed on FreeBSD, now ruby can show C level backtrace information. http://www.freebsd.org/cgi/cvsweb.cgi/ports/devel/libexecinfo/ git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@29768 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 23b12dfb17..af5274dbc5 100644
--- a/configure.in
+++ b/configure.in
@@ -1800,6 +1800,15 @@ main(int argc, char *argv[])
test x$rb_cv_fork_with_pthread = xyes || AC_DEFINE(CANNOT_FORK_WITH_PTHREAD)
fi
+AS_CASE(["$target_os"],
+[freebsd*], [
+ AC_CHECK_HEADERS([/usr/local/include/execinfo.h])
+ if test "x$ac_cv_header__usr_local_include_execinfo_h" = xyes; then :
+ RUBY_APPEND_OPTION(CPPFLAGS, -I/usr/local/include)
+ LDFLAGS="${LDFLAGS:+$LDFLAGS }-L/usr/local/lib"
+ DLDFLAGS="${DLDFLAGS:+$DLDFLAGS }-L/usr/local/lib"
+ AC_CHECK_LIB([execinfo], [backtrace])
+ fi])
AC_CHECK_FUNCS(backtrace)
AC_ARG_WITH(valgrind,