summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoryugui <yugui@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-07-31 11:31:55 +0000
committeryugui <yugui@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-07-31 11:31:55 +0000
commit53d3b13233b96b965c84ed628142b1292422319e (patch)
treedf8923d91d527235ae5ae619b8b61bec779bf0a7 /configure.in
parentf46cff647e8999b09e72fb8353de6fcd0c007cc1 (diff)
Forwardports r32772 and r32773 from branches/ruby_1_9_3 to trunk.
* common.mk (ECHO1): ":" in a make variable replacement cause a syntax error with /usr/ccs/bin/make on Solaris. Uses $(NULLCMD) instead. * configure.in (NULLCMD): new check. * Makefile.in (NULLCMD): Reflects checking in configure. * win32/Makefile.sub (NULLCMD): new assignment. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@32774 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 22 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index b278942689..49786e0d1b 100644
--- a/configure.in
+++ b/configure.in
@@ -2599,6 +2599,28 @@ AS_CASE(["$FIRSTMAKEFILE"], [*GNUmakefile:*], [gnumake=yes], [
gnumake=no])
AC_MSG_RESULT($gnumake)
])
+AS_IF([test "$gnumake" = yes], [ NULLCMD=: ], [
+ AC_MSG_CHECKING([for safe null command for ${Make-make}])
+ mkdir conftest.dir
+ echo 'A=1' > conftest.dir/Makefile
+ echo 'B=$(A:1=@:)' >> conftest.dir/Makefile
+ echo 'all:; $B 1 2 3 4 5 6 7 8 9' >> conftest.dir/Makefile
+ if (cd conftest.dir; ${Make-make} >/dev/null 2>/dev/null); then
+ NULLCMD=:
+ else
+ echo 'A=1' > conftest.dir/Makefile
+ echo 'B=$(A:1=@true)' >> conftest.dir/Makefile
+ echo 'all:; $B 1 2 3 4 5 6 7 8 9' >> conftest.dir/Makefile
+ if (cd conftest.dir; ${Make-make} >/dev/null 2>/dev/null); then
+ NULLCMD=true
+ else
+ AC_MSG_ERROR(no candidate for safe null command)
+ fi
+ fi
+ rm -fr conftest.dir
+ AC_MSG_RESULT($NULLCMD)
+])
+AC_SUBST(NULLCMD)
if test "${universal_binary-no}" = yes ; then
AC_CACHE_CHECK([for architecture macros], rb_cv_architecture_macros, [