summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoreban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2004-01-08 14:58:57 +0000
committereban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2004-01-08 14:58:57 +0000
commit50fe8ab6aa95482ea79d69e0c9891c93f6856c0d (patch)
treeb2811f50081057be8a5eb688192a72c02622c68e /configure.in
parent54d29aaba965a0405ff119dbadb70415621cc496 (diff)
* configure.in (RDOCTARGET): new macro. if you want to install
rdoc documentation, you need to run configure with --enable-install-doc. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@5419 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c51fd57b15..3c07c4e402 100644
--- a/configure.in
+++ b/configure.in
@@ -1223,6 +1223,16 @@ fi
XLDFLAGS="$XLDFLAGS -L."
AC_SUBST(ARCHFILE)
+dnl build rdoc index if requested
+RDOCTARGET=""
+AC_ARG_ENABLE(install-doc,
+ [ --enable-install-doc build and install rdoc indexes during install ],
+ [install_doc=$enableval], [install_doc=no])
+if test "$install_doc" != no; then
+ RDOCTARGET="install-doc"
+fi
+AC_SUBST(RDOCTARGET)
+
case "$target_os" in
netbsd*)
CFLAGS="$CFLAGS -pipe"