summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-02-25 03:38:00 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-02-25 03:38:00 +0000
commit4b2ac79c156b5c2cf3def5927d3291191cfaba32 (patch)
tree5eb773e7c7eaadd12bad8c23cd41c1cd790ffe69 /configure.in
parentdda5c9c0d46c8aaa71d128b9f4c91554abce80a0 (diff)
configure.in: use PACKED_STRUCT_UNALIGNED on x64-mingw
* configure.in (PACKED_STRUCT_UNALIGNED): use on x64-mingw too. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@45171 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index aa5899bb96..b3057b9802 100644
--- a/configure.in
+++ b/configure.in
@@ -1278,7 +1278,7 @@ AC_CACHE_CHECK(packed struct attribute, rb_cv_packed_struct,
if test "$rb_cv_packed_struct" = yes; then
AC_DEFINE_UNQUOTED(PACKED_STRUCT, __attribute__((packed)))
AS_CASE(["$target_cpu"],
- [x86*|x?86], [AC_DEFINE_UNQUOTED(PACKED_STRUCT_UNALIGNED, PACKED_STRUCT)],
+ [x86*|x?86|x64], [AC_DEFINE_UNQUOTED(PACKED_STRUCT_UNALIGNED, PACKED_STRUCT)],
[AC_DEFINE_UNQUOTED(PACKED_STRUCT_UNALIGNED,)])
else
AC_DEFINE_UNQUOTED(PACKED_STRUCT,)