summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorakr <akr@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2005-06-09 09:34:31 +0000
committerakr <akr@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2005-06-09 09:34:31 +0000
commit48f2d3a72d3cd92eea720a632ad71883779df708 (patch)
tree9a8e84850808c3ad7a0b7d6047aea995ca419421 /configure.in
parente1885a0079bc61b610842783fe4dd1a2a84d8a81 (diff)
* configure.in, eval.c, gc.c: use libunwind only on HP-UX.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@8598 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 4c51c0dfc8..00e4eb0f1d 100644
--- a/configure.in
+++ b/configure.in
@@ -492,7 +492,8 @@ AC_CHECK_FUNCS(fmod killpg wait4 waitpid fork spawnv syscall chroot fsync getcwd
getpriority getrlimit setrlimit\
dlopen sigprocmask sigaction _setjmp\
setsid telldir seekdir fchmod mktime timegm cosh sinh tanh\
- setuid setgid daemon)
+ setuid setgid daemon \
+ _UNW_createContextForSelf)
AC_ARG_ENABLE(setreuid,
[ --enable-setreuid use setreuid()/setregid() according to need even if obsolete.],
[use_setreuid=$enableval])
@@ -597,7 +598,7 @@ AC_C_INLINE
AC_C_VOLATILE
if test x"$target_cpu" = xia64; then
- if test x"$ac_cv_header_unwind_h" = xyes; then
+ if test x"$ac_cv_header_unwind_h" = xyes -a x"$ac_cv_func__UNW_createContextForSelf" = xyes; then
LIBS="-lunwind $LIBS"
else
AC_CACHE_CHECK(IA64 backing store member in mcontext_t, rb_cv_ia64_bspstore,