summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-04-01 10:39:27 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-04-01 10:39:27 +0000
commit48d18d3783924e912ec0d298a035cc08c9e3b675 (patch)
tree60382ff39fcf96054cbb88440edfa906815d39b5 /configure.in
parent6941189b948ad67b9b46e09fe16f3a5f5410746c (diff)
* configure.in (LIBRUBY_LDSHARED): use $(CC) instead of cc.
a patch from Wataru Kimura at [ruby-dev:38225]. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@23113 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 5f9a004c77..32027a7c81 100644
--- a/configure.in
+++ b/configure.in
@@ -1667,7 +1667,7 @@ if test "$with_dln_a_out" != yes; then
when(rhapsody*) : ${LDSHARED='cc -dynamic -bundle -undefined suppress'}
: ${LDFLAGS=""}
rb_cv_dlopen=yes ;;
- when(darwin*) : ${LDSHARED='cc -dynamic -bundle -undefined suppress -flat_namespace'}
+ when(darwin*) : ${LDSHARED='$(CC) -dynamic -bundle -undefined suppress -flat_namespace'}
: ${LDFLAGS=""}
: ${LIBPATHENV=DYLD_LIBRARY_PATH}
# /usr/local/include is always searched for
@@ -1988,7 +1988,7 @@ if test "$enable_shared" = 'yes'; then
;;
when(darwin*)
RUBY_SO_NAME="$RUBY_SO_NAME"'.$(MAJOR).$(MINOR).$(TEENY)'
- LIBRUBY_LDSHARED='cc -dynamiclib -undefined suppress -flat_namespace'
+ LIBRUBY_LDSHARED='$(CC) -dynamiclib -undefined suppress -flat_namespace'
if test "$load_relative" = yes; then
libprefix='@executable_path/../lib'
else