summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-11-06 03:07:52 +0000
committernaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-11-06 03:07:52 +0000
commit420c0430899ee0fa49f0fa84112a8eb025373cee (patch)
tree54f37a6644cd68e76024921d954f0c28812b1783 /configure.in
parent0859e7cb87a23a0e80e26d3942730d19db26834d (diff)
* configure.in (MINIDLNOBJ): set default as dmydln.o.
Now LLVM clang seems to be able to build Ruby 1.9. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@25671 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 1 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index e968ccaeef..4ce8a7b081 100644
--- a/configure.in
+++ b/configure.in
@@ -2199,7 +2199,7 @@ AC_SUBST(INSTALLDOC)
if test "$rb_with_pthread" = "yes"; then
THREAD_MODEL=pthread
fi
-MINIDLNOBJ=dln.o
+MINIDLNOBJ=dmydln.o
case "$target_os" in
when(linux*)
;;
@@ -2214,7 +2214,6 @@ case "$target_os" in
;;
when(darwin*)
RUBY_APPEND_OPTION(CFLAGS, -pipe)
- MINIDLNOBJ=dmydln.o
;;
when(human*)
AC_LIBOBJ([x68.o])
@@ -2287,7 +2286,6 @@ case "$target_os" in
LIBRUBY='lib$(RUBY_SO_NAME).a'
LIBRUBYARG='-l$(RUBY_SO_NAME)'
fi
- MINIDLNOBJ=dmydln.o
;;
when(hpux*)
case "$YACC" in
@@ -2296,7 +2294,6 @@ case "$target_os" in
YACC="$YACC -Nl40000 -Nm40000"
;;
esac
- MINIDLNOBJ=dmydln.o
;;
when(*msdosdjgpp*)
FIRSTMAKEFILE=GNUmakefile:djgpp/GNUmakefile.in