summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-08-21 16:18:02 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-08-21 16:18:02 +0000
commit404cc1ae3ff26f045d5d6d7354406e167d1ea10b (patch)
tree7d906237f631c535bb1e5b36c330f0b3d196fee3 /configure.in
parentb78fdf1a82347a0cc0ffda73cf4c7ef032ff6ea3 (diff)
configure.in: no bare case statement
* configure.in (RUBY_CHECK_SIZEOF): use single test instead of split bare case statement, so that matching parentheses would match. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@36759 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 3 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 8f08aea456..73c339537b 100644
--- a/configure.in
+++ b/configure.in
@@ -736,11 +736,8 @@ static ac__type_sizeof_ *rbcv_ptr;
done
done
}])
- m4_ifval([$2][$3], [case "${AS_TR_SH(ac_cv_sizeof_$1)}" in
- #(
- [SIZEOF_*]);;
- #(
- *)])
+ m4_ifval([$2][$3],
+ [test "${AS_TR_SH(ac_cv_sizeof_$1)@%:@SIZEOF_}" = "${AS_TR_SH(ac_cv_sizeof_$1)}" && ]){
test "$universal_binary" = yes && cross_compiling=yes
AC_COMPUTE_INT([t], AS_TR_CPP(SIZEOF_$1), [AC_INCLUDES_DEFAULT([$4])]
[${cond+$cond
@@ -754,7 +751,7 @@ ${cond+@%:@endif}
if test ${t-0} != 0; then
AS_TR_SH(ac_cv_sizeof_$1)="${AS_TR_SH(ac_cv_sizeof_$1)+${AS_TR_SH(ac_cv_sizeof_$1)-} }${t}"
fi
- m4_ifval([$2][$3], [;; esac])
+ }
: ${AS_TR_SH(ac_cv_sizeof_$1)=0}
])
{