summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorluislavena <luislavena@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-12-24 14:24:32 +0000
committerluislavena <luislavena@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-12-24 14:24:32 +0000
commit3cbf3e207d460302a90b292304169f0b07397830 (patch)
tree9a83de123e875417f37ce85e6f52f4c6d1f6592a /configure.in
parent8af67e3072e7c6a778c72de01e32988a70dd5bc5 (diff)
* configure.in: add --with-ntver option to match win32/configure.bat
functionality. Set 0x0501 as default. [ruby-core:35010] [ruby-core:35035] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@34118 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 7a6dcb61f6..9615c6068f 100644
--- a/configure.in
+++ b/configure.in
@@ -940,6 +940,14 @@ AC_ARG_ENABLE(win95,
AS_HELP_STRING([--enable-win95], [enable Windows 95 series support]),
[AS_CASE(["$enableval"],[yes|no],[enable_win95=$enableval],[unset enable_win95])])
+AC_ARG_WITH(ntver,
+ AS_HELP_STRING([--with-ntver=0xXXXX], [target NT version (default to 0x0501)]),
+ [with_ntver="$withval"], [with_ntver="0x0501"])
+AS_CASE(["$target_os"],
+[mingw*], [
+ RUBY_APPEND_OPTION(CPPFLAGS, -D_WIN32_WINNT=$with_ntver)
+])
+
AS_CASE(["$target_os"],
[freebsd*], [
AC_CACHE_CHECK([whether pthread should be enabled by default],