summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoreban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2004-01-30 17:39:04 +0000
committereban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2004-01-30 17:39:04 +0000
commit35d62eb6a5f6521ed9297d99cb723a2efc85eb19 (patch)
tree33a331ba09cfa8f3bd486de39db7e75cf6e284b6 /configure.in
parent06a45a663c978e9ee6d00617a143de7ba4175a9d (diff)
* configure.in (RPATHFLAG): set to -Wl,-R like NetBSD on Interix.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@5591 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 9792d5a6ce..e7c1ed153a 100644
--- a/configure.in
+++ b/configure.in
@@ -855,6 +855,8 @@ if test "$with_dln_a_out" != yes; then
rb_cv_dlopen=yes ;;
interix*) : ${LDSHARED="$CC -shared"}
XLDFLAGS="$XLDFLAGS -Wl,-E"
+ LIBPATHFLAG=" -L'%1\$-s'"
+ RPATHFLAG=" -Wl,-R'%1\$-s'"
rb_cv_dlopen=yes ;;
gnu*) : ${LDSHARED="$CC -shared"}
rb_cv_dlopen=yes
@@ -1211,6 +1213,9 @@ if test "$enable_shared" = 'yes'; then
LIBRUBY_DLDFLAGS='-Wl,-soname,lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR)'
LIBRUBY_ALIASES='lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR) lib$(RUBY_SO_NAME).so'
;;
+ interix*)
+ LIBRUBYARG_SHARED='-Wl,-R -Wl,${libdir} -L${libdir} -L. -l$(RUBY_SO_NAME)'
+ ;;
*)
;;
esac