summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoreban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2004-08-30 06:16:29 +0000
committereban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2004-08-30 06:16:29 +0000
commit2ebfc7e32819f1a1bc79852f5e3905c13432c299 (patch)
tree3cf1218cf54d4d23f24f5278cb45b3cf92651342 /configure.in
parent2ca3c51719daafae497d689c48dd06187529cb4c (diff)
* configure.in (GNU/k*BSD): fixed FTBFS on GNU/k*BSD. [ruby-dev:24051]
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@6834 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 5 insertions, 13 deletions
diff --git a/configure.in b/configure.in
index 89a9ba8068..b82c6b19bd 100644
--- a/configure.in
+++ b/configure.in
@@ -792,7 +792,7 @@ if test "$rb_cv_binary_elf" = yes; then
fi
case "$target_os" in
-linux*)
+linux* | gnu* | k*bsd*-gnu)
if test "$rb_cv_binary_elf" = no; then
with_dln_a_out=yes
else
@@ -873,15 +873,13 @@ if test "$with_dln_a_out" != yes; then
rb_cv_dlopen=yes ;;
osf*) : ${LDSHARED="ld -shared -expect_unresolved \"*\""}
rb_cv_dlopen=yes ;;
- linux*) : ${LDSHARED="$CC -shared"}
+ linux* | gnu* | k*bsd*-gnu)
+ : ${LDSHARED="$CC -shared"}
rb_cv_dlopen=yes ;;
interix*) : ${LDSHARED="$CC -shared"}
XLDFLAGS="$XLDFLAGS -Wl,-E"
LIBPATHFLAG=" -L'%1\$-s'"
rb_cv_dlopen=yes ;;
- gnu*) : ${LDSHARED="$CC -shared"}
- rb_cv_dlopen=yes
- LDFLAGS="$LDFLAGS -rdynamic" ;;
freebsd*|dragonfly*) : ${LDSHARED="$CC -shared"}
if test "$rb_cv_binary_elf" = yes; then
LDFLAGS="$LDFLAGS -rdynamic"
@@ -1031,9 +1029,7 @@ else
fi
case "$target_os" in
- linux*)
- STRIP='strip -S -x';;
- gnu*)
+ linux* | gnu* | k*bsd*-gnu)
STRIP='strip -S -x';;
nextstep*)
STRIP='strip -A -n';;
@@ -1179,11 +1175,7 @@ if test "$enable_shared" = 'yes'; then
sunos4*)
LIBRUBY_ALIASES='lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR) lib$(RUBY_SO_NAME).so'
;;
- linux*)
- LIBRUBY_DLDFLAGS='-Wl,-soname,lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR)'
- LIBRUBY_ALIASES='lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR) lib$(RUBY_SO_NAME).so'
- ;;
- gnu*)
+ linux* | gnu* | k*bsd*-gnu)
LIBRUBY_DLDFLAGS='-Wl,-soname,lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR)'
LIBRUBY_ALIASES='lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR) lib$(RUBY_SO_NAME).so'
;;